Custom Search

Saturday, 22 November 2008

Latest Pass4sure ccnp 642 901 on 4shared

Latest Pass4sure ccnp 642-901 on 4shared


Link 1 Link 2 Link 3 


Enjoy

4 comments:

All BSCI labs sims explanations said...

his will be the last and final update : 26 February 2009
=================================

Labs on the BSCI exam :

- EIGRP & IS-IS redistribution ( P4S )
- OSPF Configuration Area Types ( Stub / Stub No-summary ) ( P4S )
- IPv6 OSPF virtual link lab ( not in P4S )
- EIGRP summarization ( not in P4S )

Fair bit of BGP, Multicast and IPv6. In fact quite alot of IPv6 so study up on this and make sure you are clued up on 6to4 tunnelling etc...
Quite alot of questions on identifying advantages and similarities of different routing protocols.
Suprisingly, there was alot of EIGRP aswell so make sure you know this too.

-------------------------------------
OSPF virtual link lab in OSPFv3
Area0 Area11 51
RA -------- RB -------- RC--------RD

RID of Router A : 1.1.1.1
RID of Router B: 2.2.2.2
RID of Router C: 3.3.3.3
RID of Router D: 4.4.4.4

IPV6 addresses (not in my mind right now...n by the way we don't need to remeber those IPs n just need those to verify our Virtual link configs..)


Configuring virtual link

Router B
===========
look at the ospf process by show run

config # router ipv6 ospf (Process no)
config-router# area 11 virtual-link 3.3.3.3

Router C
===========
look at the ospf process by show run

config # router ipv6 ospf (Process no)
config-router# area 11 virtual-link 2.2.2.2

As per cisco for getting 100% score in sim, we have to remove some errored config as well...What i observed was wrong virtual link configs on RB,RC, n RD. So removed wrong configs (Just type "no" infront of wrongly confgured commands.

By the way i just got 80% in that lab. So might be something else was there which i missed.

In order to confrim the config, just use sh ipv6 ospf virtual-links on both RB n RC, n confirm tht VL is established n up.
then u can also show the IPV6 routes of RD at RA by typing sh ipv6 route at RA n RD. Wasn't able to ping the IPs as command was not supported in tht sim, but cisco has said that we can run tht command on given sim....
======================================================
OSPF virtual link lab :

1. OSPF virtual link I have never encountered. area 0 -- area 53 - -area 112 , 1 router in each must be able to ping IPv6 loopback address on area 112 router from router in area 0, I have NFI how to ping IPv6 addresses so I created a virt link through area 53 maybe it worked it showed up in >#show ip route.
OSPF Virtual Link Lab :


R1 (fa0/0)----area0------(fa0/0) R2 (fa0/1)-----area11------(fa0/1) R3 (fa0/0) -----area53-----(fa0/0) R4

I considered on each router one loopback interface with IPv4. Also i considered on each the following ipv6 addresses:

R1 Lo0: 1.1.1.1/32
R2 Lo0: 2.2.2.2/32
R3 Lo0: 3.3.3.3/32
R4 Lo0: 4.4.4.4/32

R1 fa0/0: 2001::10/64
R2 fa0/0: 2001::11/64

R2 fa0/1: 2002::10/64
R3 fa0/1: 2002::11/64

R3 fa0/0: 2003::10/64
R4 fa0/0: 2003::11/64

R1
==

int lo0
ip add 1.1.1.1 255.255.255.255
exit

int fa0/0
ipv6 add 2001::10/64
no shut
ipv6 ospf 1 area 0
exit

ipv6 unicast-routing

ipv6 router ospf 1
router-id 1.1.1.1
exit

R2
==


int lo0
ip add 2.2.2.2 255.255.255.255
exit

int fa0/0
ipv6 add 2001::11/64
no shut
ipv6 ospf 1 area 0
exit

int fa 0/1
ipv6 add 2002::10/64
no shut
ipv6 ospf 1 area 11
exit

ipv6 unicast-routing

ipv6 router ospf 1
router-id 2.2.2.2
exit


R3
==


int lo0
ip add 3.3.3.3 255.255.255.255
exit

int fa0/0
ipv6 add 2002::11/64
no shut
ipv6 ospf 1 area 11
exit

int fa 0/1
ipv6 add 2003::10/64
no shut
ipv6 ospf 1 area 53
exit

ipv6 unicast-routing

ipv6 router ospf 1
router-id 3.3.3.3
exit

R4
==


int lo0
ip add 4.4.4.4 255.255.255.255
exit

int fa0/0
ipv6 add 2003::11/64
no shut
ipv6 ospf 1 area 53
exit

ipv6 unicast-routing

ipv6 router ospf 1
router-id 4.4.4.4
exit


R1#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2001::/64 [0/0]
via ::, FastEthernet0/0
L 2001::10/128 [0/0]
via ::, FastEthernet0/0
OI 2002::/64 [110/2]
via FE80::C801:EFF:FEF4:8, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
L FF00::/8 [0/0]
via ::, Null0
R1#ping 2001::11

Virtual link configuration on R2 and R3

R2
==

ipv6 router ospf 1
area 11 virtual-link 3.3.3.3
exit

R3
==

ipv6 router ospf 1
area 11 virtual-link 2.2.2.2
exit

R1#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2001::/64 [0/0]
via ::, FastEthernet0/0
L 2001::10/128 [0/0]
via ::, FastEthernet0/0
OI 2001::11/128 [110/1]
via FE80::C801:EFF:FEF4:8, FastEthernet0/0
OI 2002::/64 [110/2]
via FE80::C801:EFF:FEF4:8, FastEthernet0/0
OI 2003::/64 [110/3]
via FE80::C801:EFF:FEF4:8, FastEthernet0/0
OI 2003::10/128 [110/2]
via FE80::C801:EFF:FEF4:8, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
L FF00::/8 [0/0]
via ::, Null0

======================================================
EIGRP Lab :

The second question was EIGRP !BUGGY! LAB. I was stressed so much, buggy unknown STUPID WORDING SCENARIO lab in the beginning
3 EIGRP routers, 3 console PC for each, the simlet is not comfortable at all,
you have to switch between consoles through topology map although they r tabbed in main status lane.
After some time configuring the lab, the STUB router console asked for the username and pass, although I did
nothing to timeout session, no pass worked anyway, no pass in the scenario. WEIRD.
I beleive the lab is about stub without 'receive only' and 'ip summary address' on interface of neighboring router.
So I pinged stub rotuer's interface from the remote one, configured ip summaryr address on int leading to stub,
did copy ru sta on other 2 routers and clicked NEXT.

I can't remember the whole scenario, but the task is to configure R3 that it will advertise its routes to other eigrp routers, and configure summarization. The topology is like,

((R3))--------((R4))--------((R2)),

Step 1 :
you should be able to ping R3 lan interface from R2, to do this, just
- remove the "eigrp stub receive-only" command from the eigrp process
- configure "eigrp stub". It will advertise the routes to R2, and R4...

Step 2 :
Now the next step is to configure summarization, in the test it is like, R3 should have only two subnets of 10.0.0.0...

go to R4 *** serial interface *** connected to R3, and isuue the command,
- ip summary-address eigrp 123 10.2.2.0 255.0.0.0
- ip summary-address eigrp 123 10.2.3.0 255.0.0.0

There are no mask given, so i used default, i think the network 10.2.2.0 was running between R3 and R4, and 10.2.3.0 between R4 and R2..
10.x.x.x-((R3))--------((R4))--------((R2))

===============================================

EIGRP & IS-IS redistribution ( P4S )

Question : Trebuchet Enterprises recently completed merging with Oxybeles Endeavors. The two Companies have been using separate routing protocols on their corporate networks, and an immediate solution is required for the two companies to begin sharing data. A boundary router, Blockade has been established to perform mutual redistribution of route information between the two networks. Configure route redistribution from EIGRP into IS-IS and from IS-IS into EIGRP on the boundary router per the following requirements:

Seed metric for EIGRP must have the following characteristics :
Bandwidth = 512 kbps
Delay = 100
Reliability = 255
Load = 1
MTU = 1500

Seed metric for IS-IS must be set to 50.
Only redistribute Level-1 IS-IS routes into EIGRP.
Redistribute EIGRP routes into IS-IS as Level-1 routes.

Blockade# conf t
Blockade (config)# router isis
Blockade (config-router)# redistribute eigrp 100 level-1 metric 50
Blockade (config-router)# exit
Blockade (config)# router eigrp 100
Blockade (config-router)# redistribute isis level-1 metric 512 10 255 1 1500
Blockade (config-router)# redistribute connected
Blockade (config-router)# exit
Blockade (config)# end
Blockade# copy run start

Long answer :

Select the console port on BLOCKADE
Redistributing EIGRP routes into IS-IS as Level-1 routes with a seed metric of 50.

Blockade# configure terminal
Blockade(config)# router isis
#Enters into isis routing process

Blockade(config-router)# redistribute eigrp 100 level-1 metric 50
#Eigrp 100 : Identify the EIGRP AS Number using the show run command on blockade or trebuchet router.
#Level-1 : Specifies the Level the EIGRP routes are redistributed into ISIS.
#Metric 50 : The redistributed routes have a seed metric of 50.

#Redistributing IS-IS Level-1 routes into EIGRP with seed metric
#Bandwidth 512 kbps; Delay=100; Reliability = 255; Load = 1 and MTU = 1500

Blockade(config)# router eigrp 100
#Identify the EIGRP AS Number by using the show run command on blockade.

Blockade (config-router) # redistribute isis level-1 metric 512 10 255 1 1500
#isis level-1 this keyword will only redistribute isis level-1 routes into EIGRP
#metric 512 10 255 1 1500
#seed metric of EIGRP.
#metric {bandwidth} {delay} {reliability} {load} {MTU}
#{Bandwidth}: in kbps
#{Delay}: expressed in units of tens of micro seconds

#Important:
#Remember when Delay is given has 100
#You must divide by 10 to get exact value to configure i.e
#Delay = 100/10 = 10 (tens of microseconds)
#If delay is 5 ms (milliseconds)
#5 *1000 = 5000 microseconds
#5000/10 = 500 (tens of micro seconds)
#Delay = 500

Blockade (config-router) # redistribute connected
#redistribute connected
#When you use "redistribute connected" within your routing protocol, it automatically brings the connected networks/#subnets into the routing protocol, just as if you had used multiple "network" commands within the routing protocol.
#" redistribute connected " is used at EIGRP to advertise its directly connected networks to its neighbors #irrespective of these directly connected networks are part of any routing protocols.
#Purpose of using redistribute connected here is to advertise the Host B network (Not part of EIGRP domain ) to its #neighbors since we are not provided with its network information in exhibit, Sametime it also advertise S0/0 and S #0/1 of blockade router networks to others.
Read more about it here : http://ccnprecertification.com/2005/11/22/redistribution-involving-is-is/


Blockade (config-router) # end

Blockade #copy runnig-config startup-config
#To save running config to startup before exit.


Verifying Configuration:
Go to Trebuchet router
Verify the ISIS routes are redistributed into EIGRP domain
Using the show ip route or show eigrp topology command

Go to Oxybeles router
Verify EIGRP routes are redistributed into ISIS domain using show ip route command

==================================================

OSPF Configuration Area Types ( Stub / Stub No-summary ) ( see BSCI-ospf.jpg ) :

Answer:
Configure Portland router

Portland# configure terminal
Portland(config)# router ospf 1
Portland(config-router)# network 192.168.5.4 0.0.0.3 area 1
Portland(config-router)# area 1 stub
Portland(config-router)# end
Portland#copy run start

Configure Indianapolis router

Indianapolis# configure terminal
Indianapolis(config)# router ospf 1
Indianapolis(config-router)# network 192.165.5.4 0.0.0.3 area 1
Indianapolis(config-router)# area 1 stub no-summary
Indianapolis(config-router)# end
Indianapolis# copy run start

Explanation:

The tasks that needs to be configured are
Task1: Portland’s S 0/0 interface in Area 1
Task 2: Indianapolis’s S0/1 interface in Area 1
Task 3: Appropriate mask such that ONLY Portland S 0/0 and Indianapolis S 0/1
Could be in Area 1
Task4: Area 1 should not receive any external or inter-area routes (except the default route)

For task1 use the network command at ospf routing process mode on Portland router to advertise the network 192.165.5.4 in Area 1.

Since task 3 requires we only use a mask that ONLY

Portland S 0/0 and Indianapolis S 0/1 belongs to Area 1.
Wild card mask needed to achieve above task3 is 0.0.0.3

Result network statement on Portland router for task1 and task3 will be

Portland(router-config)#network 192.165.5.4 0.0.0.3 area 1

Similarly for Indianapolis router result network statement for task2 and task 3 will be

Indianapolis(router-config)#network 192.165.5.4 0.0.0.3 area 1


Task 4 requires that Area 1 should not receive any external or inter-area routes
(Except the default route)

Configuring an area as a stub area forces its ABR (Area Border Router) to drop all external (type 5) routes and replaces them with a default route.
To limit routing information even more, an area can be made totally stubby using the
no-summary keyword on the ABR only. In that case, all interarea and external routes are dropped by the ABR and replaced by a default route.

For the above SIM Indianapolis router is ABR.

Configure area 1 on Portland router as stub area

Portland(config-router)#area 1 stub

Configure area 1 on Indianapolis as totally stubby area by using the keyword no-summary so that area 1 will not receive both external and inter-area routes except default route.

Indianapolis(config-router)# area 1 stub no-summary


By configuring the above two statements on respective routers we achieve task 4.

Important: To save running config to startup before exit.

Indianapolis #copy running-config startup-config

Portland# copy running-config startup-config


Verifying Configuration:

show ip ospf interface command shows the
interfaces on which OSPF runs and their current correct assigned area.

Use the command show ip route on Portland router
To check the type of ospf routes that is advertised into Portland from Indianapolis .


==========================================================

EIGRP Simlet ( See Testlet-EIGRP.JPG ) :

BusyMoney Incorporated is a worldwide finance provider. The network uses EIGRP as its routing protocol throughout the corporation. The network administrator does not understand the convergence of EIGRP. Using the output of the show ip eigrp topology all-links command, answer the administrators questions:

Question 1:
Which three EIGRP routes will be installed for the 172.20.3.128 /25 and 172.20.2.0/24 networks? (choose three)

(A) D 172.20.3.128 /25 [90/28160] via 172.20.1.2 0135. FastEthernet 0/2
(B) D 172.20.3.128 /25 [90/30720] via 172.20.3.2 0135. FastEthernet 0/3
© D 172.20.3.128 /25 [90/30720] via 172.20.10.2 0135. FastEthernet 0/1
(D) D 172.20.2.0 /24 [90/30720] via 172.20.10.2 02 11. FastEthernet 0/1
(E) D 172.20.2.0 /24 [90/28160] via 172.20.10.2 02 11. FastEthernet 0/1
(F) D 172.20.2.0 /24 [90/33280] via 172.20.3.2 02 11. FastEthernet 0/1

Answers: B C D

Explanation:
The path with the lowest metric is called the successor
path. This successor routes are installed into the routing table.
Multiple successor routes for particular network can exist in routing table.

Question 2:
Which three networks does the Switch1 device have feasible successors for?
(Choose three)
(A) 172.20.10.0 /30
(B) 172.20.1.0 /24
© 172.20.2.0 /24
(D) 172.20.3.0 /25
(E) 172.20.3.128 /25
(F) 10.69.0.0 /24

Answers: A C F

Explanation:
EIGRP paths with a lower AD than the FD of the successor path
are guaranteed loop-free and called feasible successors.

Since networks 172.20.10.0 /30, 172.20.2.0 /24 and 10.69.0.0 /24 all have routes with Advertise distance less or equal to that of feasible distance of successor route respectively.

Question 3:
Which three networks is the router at 172.20.10.2 directly connected to?
(Choose three)

(A) 172.20.0.0 /30
(B) 172.20.1.0 /24
© 172.20.2.0 /24
(D) 172.20.3.0 /25
(E) 172.20.3.128 /25
(F) 172.20.10.0 /24

Answers: C E F

Pass 642-901 BSCI said...

Hi today i passed bsci with 911/1000
3 lab + ospf IPV6 61 question (about P4S e Actualtest 45 the rest i work serious)
Thanks . Good blog

Hanuki from Japan said...

Thanks for infomation .

Anonymous said...

Hi I passed BSCI yesterday .
Exam contained 3 simulations : OSPFv3 virtual-link, IS-IS - EIGRP redistribution, OSPF area configuration. If you study carefully you won't have any problems in passing BSCI. Some questions are tricky so read carefull instruction and command outputs

Post a Comment

Comment Here

More Post